Eurotehnik.ru

Бытовая Техника "Евротехник"
0 просмотров
Рейтинг статьи
1 звезда2 звезды3 звезды4 звезды5 звезд
Загрузка...

Как найти повторяющиеся ячейки в excel

Как найти повторяющиеся ячейки в excel

​Смотрите также​ одинаковые значения, например:​A3​Выберите стиль форматирования и​ Следуйте инструкции ниже,​(Conditional Formatting >​ Это очень ресурсоемкая​ (столбец С) автоматически​ИсхСписок- это Динамический диапазон​ значения, которые повторяются.​ Как убрать повторяющиеся​

​ способов найти одинаковые​ нам нужно выделить:​Первый способ.​

​Нажмите кнопку​​Перед попыткой удаления​>​В некоторых случаях повторяющиеся​12​

​:​​ нажмите​​ чтобы выделить только​​ Highlight Cells Rules)​​ задача и годится​​ будет обновлен, чтобы​​ (ссылка на исходный​​ Дополнительное условие: при​​ значения в Excel,​

Правила выделения ячеек

​ значения в Excel​ повторяющиеся или уникальные​​Как найти одинаковые значения​​ОК​ повторений удалите все​Повторяющиеся значения​ данные могут быть​​45​​=СЧЕТЕСЛИ($A$1:$C$10;A3)=3 и т.д.​

Диалоговое окно

Удаление повторяющихся значений

​ОК​​ те значения, которые​​ и выберите​ для небольших списков​ включить новое название​ список в столбце​ добавлении новых значений​ смотрите в статье​ и выделить их​

​ значения. Выбираем цвет​ в Excel​.​

​ структуры и промежуточные​​.​ полезны, но иногда​12​Обратите внимание, что мы​.​

​ встречающиеся трижды:​​Повторяющиеся значения​​ 50-100 значений. Если​​3. Добавьте в исходный​​А​​ в исходный список,​​ «Как удалить дубли​ не только цветом,​ заливки ячейки или​.​

Удалить повторения

​Рассмотрим,​ итоги из своих​В поле рядом с​ они усложняют понимание​6​

Выделенные повторяющиеся значения

​ создали абсолютную ссылку​​Результат: Excel выделил значения,​​Сперва удалите предыдущее правило​​(Duplicate Values).​​ динамический список не​

Диалоговое окно

​ список название новой​​).​​ новый список должен​

1. Удаление повторяющихся значений в Excel (2007+)

Предположим, у вас имеется таблица, состоящая из трех столбцов, в которой присутствуют одинаковые записи и вам необходимо избавится от них. Выделяем область таблицы, в которой хотите удалить повторяющиеся значения. Вы можете выделить один или несколько столбцов, или всю таблицу целиком. Переходим по вкладке Данные в группу Работа с данными, щелкаем по кнопке Удалить дубликаты.

удалить-дубликаты excel

Если в каждом столбце таблицы имеется заголовок, установить маркер Мои данные содержат заголовки. Также проставляем маркеры напротив тех столбцов, в которых требуется произвести поиск дубликатов.

Читайте так же:
Как в excel сделать ссылку на картинку

удалить-дубликаты excel

Щелкаем ОК, диалоговое окно будет закрыто и строки, содержащие дубликаты будут удалены.

Данная функция предназначена для удаления записей, которые полностью дублируют строки в таблице. Если вы выделили не все столбцы для определения дубликатов, строки с повторяющимися значениями также будут удалены.

Как вычислить повторы при помощи сводных таблиц

Метод хорош тем, что мы не только определяем повторяющиеся значения в Excel, но и пересчитываем их. Причём делаем это за считанные минуты. Правда, есть и минус – столбец с данными может быть всего один.

Вернёмся к нашим баранам футболистам. Я оставил один столбик, добавив в него ячейки-дубли, а также дописал заглавную строку (это обязательно).

Столбик из имен футболистов

Далее делаем следующее:

Шаг 1. В ячейках напротив фамилий проставляем единички. Вот так:

Дописываем второй столбик

Шаг 2. Переходим в раздел «Вставка» главного меню и в блоке «Таблицы» выбираем «Сводная таблица».

Пункт сводная таблица

Откроется окно «Создание сводной таблицы». Здесь нужно выбрать диапазон данных для анализа (1), указать, куда поместить отчёт (2) и нажать «ОК».

Поля сводной таблицы

Только не ставьте галку напротив «Добавить эти данные в модель данных». Иначе Эксель начнёт формировать модель, и это парализует ваш комп на пару минут минимум.

Шаг 3. Распределите поля сводной таблицы следующим образом: первое поле (в моём случае «Футболисты») – в область «Строки», второе («Значение2») – в область «Значения». Используйте обычное перетаскивание (drag-and-drop).

Перетаскиваем поля

Должно получиться так:

Строки и значения

А на листе сформируется сама сводка — уже без дублированных ячеек. Зато во втором столбике будет указано, сколько ячеек-дублей с конкретным содержанием было обнаружено в первом столбике (например, Онопко – 2 шт.).

Готовая сводная таблица

Этот метод «на бумаге» может выглядеть несколько замороченным, но уверяю: попробуете раз-два, набьёте руку, а потом все операции будете выполнять за минуту.

Как объединить одинаковые строки одним цветом?

Чтобы найти объединить и выделить одинаковые строки в Excel следует выполнить несколько шагов простых действий:

  1. Выделите весь диапазон данных табличной части A2:F18. Начинайте выделять значения из ячейки A2, так чтобы после выделения она оставалась активной как показано ниже на рисунке. И выберите инструмент: «ГЛАВНАЯ»-«Стили»-«Условное форматирование»-«Создать правило». Создать правило1.
  2. В появившемся окне «Создание правила форматирования» выберите опцию: «Использовать формулу для определения форматированных ячеек». СЦЕПИТЬ.
  3. В поле ввода введите формулу: 1′ >Зеленая заливка.
  4. Нажмите на кнопку формат, чтобы задать цвет заливки для ячеек, например – зеленый. И нажмите на всех открытых окнах кнопку ОК.
Читайте так же:
Как в ворде сделать сетку клетки

В результате выделились все строки, которые повторяются в таблице хотя-бы 1 раз.

Как выбрать строки по условию?

Форматирование для строки будет применено только в том случаи если формула возвращает значения ИСТИНА. Принцип действия формулы следующий:

Первая функция =СЦЕПИТЬ() складывает в один ряд все символы из только одной строки таблицы. При определении условия форматирования все ссылки указываем на первую строку таблицы.

Абсолютные и относительные адреса ссылок в аргументах функций позволяют нам распространять формулу на все строки таблицы.

Вторая функция =СЦЕПИТЬ() по очереди сложить значение ячеек со всех выделенных строк.

Обе выше описанные функции работают внутри функции =ЕСЛИ() где их результаты сравниваются между собой. Это значит, что в каждой ячейке выделенного диапазона наступает сравнение значений в текущей строке со значениями всех строк таблицы.

Как только при сравнении совпадают одинаковые значения (находятся две и более одинаковых строк) это приводит к суммированию с помощью функции =СУММ() числа 1 указанного во втором аргументе функции =ЕСЛИ(). Функция СУММ позволяет сложить одинаковые строки в Excel.

Если строка встречается в таблице только один раз, то функция =СУММ() вернет значение 1, а целая формула возвращает – ЛОЖЬ (ведь 1 не является больше чем 1).

Если строка встречается в таблице 2 и более раза формула будет возвращать значение ИСТИНА и для проверяемой строки присвоится новый формат, указанный пользователем в параметрах правила (заливка ячеек зеленым цветом).

4. Использование сводных таблиц для определения повторяющихся значений

Воспользуемся уже знакомой нам таблицей с тремя столбцами и добавим четвертый, под названием Счетчик, и заполним его единицами (1). Выделяем всю таблицу и переходим по вкладке Вставка в группу Таблицы, щелкаем по кнопке Сводная таблица.

Читайте так же:
Как в excel посчитать сумму строки автоматически

Создаем сводную таблицу. В поле Название строк помещаем три первых столбца, в поле Значения помещаем столбец со счетчиком. В созданной сводной таблице, записи со значением больше единицы будут дубликатами, само значение будет означать количество повторяющихся значений. Для большей наглядности, можно отсортировать таблицу по столбцу Счетчик, чтобы сгруппировать дубликаты.

Как вычислить повторы при помощи сводных таблиц

Метод хорош тем, что мы не только определяем повторяющиеся значения в Excel, но и пересчитываем их. Причём делаем это за считанные минуты. Правда, есть и минус — столбец с данными может быть всего один.

Вернёмся к нашим баранам футболистам. Я оставил один столбик, добавив в него ячейки-дубли, а также дописал заглавную строку (это обязательно).

Далее делаем следующее:

Шаг 1. В ячейках напротив фамилий проставляем единички. Вот так:

Шаг 2. Переходим в раздел «Вставка» главного меню и в блоке «Таблицы» выбираем «Сводная таблица».

Откроется окно «Создание сводной таблицы». Здесь нужно выбрать диапазон данных для анализа (1), указать, куда поместить отчёт (2) и нажать «ОК».

Только не ставьте галку напротив «Добавить эти данные в модель данных». Иначе Эксель начнёт формировать модель, и это парализует ваш комп на пару минут минимум.

Шаг 3. Распределите поля сводной таблицы следующим образом: первое поле (в моём случае «Футболисты») — в область «Строки», второе («Значение2») — в область «Значения». Используйте обычное перетаскивание (drag-and-drop).

Должно получиться так:

А на листе сформируется сама сводка — уже без дублированных ячеек. Зато во втором столбике будет указано, сколько ячеек-дублей с конкретным содержанием было обнаружено в первом столбике (например, Онопко — 2 шт.).

Читайте так же:
Можно ли заменить электролитические конденсаторы на твердотельные

Этот метод «на бумаге» может выглядеть несколько замороченным, но уверяю: попробуете раз-два, набьёте руку, а потом все операции будете выполнять за минуту.

Удаление дубликатов в Microsoft Excel

Для меня человека который проводит время в отпуске и работает с мобильного интернета скорость которого измеряется от 1-2 мегабита, прокачивать в пустую такое кол-во товара с фотографиями смысла не имеет и время пустое и трафика сожрет не мало, поэтому решил повторяющиеся товары просто удалить и тут столкнулся с тем, что удалить дублирующиеся значения в столбце не так то и просто, потому как стандартная функция excel 2010 делает это топорно и после удаления дубликата двигает вверх нижние значения и в итоге у нас все перепутается в документе и будет каша.

В данной статье будет представлено два варианта решения проблемы.

1 Вариант — Стандартная функция в эксель — Удалить дубликаты

Я не могу пропустить этот вариант, хоть он и самый примитивный но может это то, что именно Вы искали для своей ситуации, поэтому давайте рассмотрим тот функционал который идет из коробки самого экселя

Для этого выделим те столбцы или область в какой надо удалить дубликаты и зайдем в меню Данные и потом выберем Удалить дубликаты, после чего у нас удаляться дубликаты, но будет сдвиг ячеек, если для вас это не критично, то этот способ Ваш!

эксель удалить дубликаты

2 Вариант — Пометить дубликаты строк в Лож или Истина

Этот вариант самый простой и отсюда сразу вылетает птичка которая ограничит этот вариант в действии, а именно в том, что им можно воспользоваться если у вас все дублирующие значения идут по порядку, а не в разнобой по всему документу

excel дубли

для примера возьмем два столбика с данными, в одном (пример1) дублирующие значения повторяются, а в (примере2) в разнобой и не идут друг за другом.

удалить дубли в excel

В примере1 мы должны в стоящей рядом ячейки нажать знак ровно и выбрать первое и нижние значение что бы формула была такая:

Читайте так же:
Где анимация в фотошопе cs6

и нажимаем энтер, и у нас в этой ячейки в зависимости от данных должно появится значение Лож или Истина

как убрать дубли в excel

ЛОЖ — если А1 не будет равно А2

Истина — если А1 будет ровно А2

если применить этот вариант на столбце Пример2, то как вы поняли везде будет значение Лож

как найти дубли в столбце в excel

Этот вариант хорош только в редких случаях, но его тоже надо знать, его ограничение в том что эта формула сравнивает себя и следующее значение, тоесть она применима только одновременно к двум ячейкам, а не ко всему столбцу. Но если у вас данные как с столбце Пример2, тогда читайте дальше )

3 Вариант — Удалить дубликаты в столбе

Вот этот вариант уже более сложный, но он решит вашу проблему на все 100% и сразу ответит на все вопросы.

Как видим у нас имеется столбец в котором все значения идут не по порядку и они перемешаны

как выделить дубли в экселе

Мы как и в прошлый раз в соседнюю ячейку вставляем следующую формулу

После применения которой у нас будет либо пуская ячейка, либо значение из ячейки напротив.

excel как выделить дубли в столбце

из нашего примера сразу видно, что в этом столбце было два дубля и эта формула нам значительно сэкономила времени, а дальше фильтруем второй столбец и в фильтре выбираем пустые ячейки и дальше удаляем строки, вот и все)

Таким образом я в документе который который скачал у поставщика создал перед артикулом пустой столбце и далее применил эту формулу и после отфильтровав получил документ который был на 6-8 тыс строк меньше и самое главное после удаление дубликатов у меня не поднимались значения вверх, все стояло на своих местах

Надеюсь статья была полезная, если не поняли я прикрепил к каналу видео смотрите его или задавайте вопросы,

голоса
Рейтинг статьи
Ссылка на основную публикацию
Adblock
detector