Eurotehnik.ru

Бытовая Техника "Евротехник"
0 просмотров
Рейтинг статьи
1 звезда2 звезды3 звезды4 звезды5 звезд
Загрузка...

КАК: Как использовать операторы сравнения в Excel — 2021

КАК: Как использовать операторы сравнения в Excel — 2021

Table of Contents:

Операторы сравнения — это символы, используемые в формулах Excel для сравнения двух значений и вывода желаемого результата. Результатом такого сравнения может быть TRUE или FALSE или любое другое значение вывода, которое вы указываете вместо истинного или ложного условия.

Заметка Информация в этой статье относится к версиям Excel 2019, 2016, 2013, 2010, Excel Online и Excel для Mac.

Excel больше или равно

В Excel мы будем выполнять несколько логических операций с помощью логических операторов, таких как IF, OR, AND, NOT и т. Д. В дополнение к логическим операторам мы также используем операторы сравнения для сравнения различных источников данных, чтобы проверить, есть ли сходство или не между двумя источниками.

Следовательно, операторы сравнения играют жизненно важную роль в выполнении логических операций. Доступно 6 операторов сравнения:

> (Больше) : этот оператор сравнивает один элемент данных с другим элементом данных и проверяет, больше он или нет. Если условие больше, чем условие удовлетворяет, он возвращает «True», иначе «False».

<(Меньше чем): этот оператор сравнивает один элемент данных с другим элементом данных и проверяет, меньше ли он или нет. Если условие меньше условия, возвращается «True», иначе «False».

= (Равно): этот оператор сравнивает один элемент данных с другим элементом данных и проверяет, равен он или нет. Если выполняется равное условие, возвращается «True», иначе «False».

> = (Больше или равно): этот оператор сравнивает один элемент данных с другим элементом данных и проверяет, является ли он больше или равен или нет. Если условие больше или равно удовлетворению, возвращается «True», иначе «False».

<= (Меньше или равно) : этот оператор сравнивает один элемент данных с другим элементом данных и проверяет, является ли он меньше или равен или нет. Если условие меньше или равно условию, оно возвращает «True», иначе «False».

(Не равно) : этот оператор сравнивает один элемент данных с другим элементом данных и проверяет, является ли он «Не равен» или нет. Если условие «Не равно» удовлетворяет, возвращает «Истина», в противном случае «Ложь».

Как использовать больше или равно в Excel?

В этой теме мы собираемся обсудить «Больше или равно», поэтому сначала мы увидим, как работают операторы «Больше чем» и «Равно» и как оба работают вместе.

Давайте рассмотрим несколько примеров, чтобы понять, как использовать «Больше чем» или «Равно» в Excel.

Вы можете скачать этот шаблон больше или равно Excel здесь — Больше или равно шаблон Excel

Больше или равно в Excel — Пример № 1

Больше, чем оператор в Excel:

Синтаксис больше, чем A> B

где A и B — числа или текст.

Посмотрите на картинку выше «True» в ячейке F6, но если мы наблюдаем столбец формулы, то это = 10> 5. Поскольку условие истинно, оно возвращает «Истина».

Больше или равно в Excel — Пример № 2

Теперь мы увидим оператор «Больше чем» в логических операциях, использующих IF. Предположим, нам нужно выяснить, в какие месяцы продажи компании превышают средние продажи за квартал.

На изображении выше соблюдайте формулу B1 (продажи за месяц) по сравнению с C5 (средние продажи), поскольку продажи за месяц больше средних продаж, которые возвращаются. Высокие продажи. Так как продажи за второй месяц меньше, чем средние продажи, следовательно, возвращается Низкие продажи.

Больше или равно в Excel — Пример № 3

Равный оператор в Excel:

Синтаксис оператора Equal равен A = B

где A и B — значения данных.

Обратите внимание, что изображение 5 = 5 представлено как Истина, поскольку это действительное условие.

Заметьте, что приведенное выше изображение 8 = 5 неверно, следовательно, возвращает false.

Больше или равно в Excel — Пример № 4

Сравнение строк с использованием Equal Operator в Excel:

Теперь, когда мы увидим пример с числами, мы увидим, как оператор равенства помогает сравнивать строки.

Обратите внимание на приведенную выше картинку, которую мы хотим сравнить, соответствует ли имя имени чандре формуле. Поскольку B7 совпадает с E1, значит, оно возвращает True.

Больше или равно в Excel — Пример № 5

Больше или равно применению к числам:

Синтаксис « Больше или равно»: A> = B, где A и B — числовые или текстовые значения. В операторе «Больше или равно» значение A сравнивается со значением B, оно возвращает true в двух случаях: один — когда A больше B, а другой — когда A равен B.

Соблюдайте формулу в C1, 10> = 8 возвращает True, потому что 10 может не равняться 8, а 10 больше 8.

Обратите внимание на изображение выше в ячейке, C1 7> = 7 возвращает True, потому что 7 не больше 7, но 7 равно 7, следовательно, оно возвращает true.

Обратите внимание, что ячейка изображения C1, 6> = 7 возвращает значение False, поскольку значение 6 не больше 7, а значение 6 не равно 7, поскольку в обоих случаях неудача возвращает значение False.

Читайте так же:
Мкб зарегистрироваться в личном кабинете

Больше или равно в Excel — Пример № 6

Решение условий с использованием Greater than или Equal в Excel:

Предположим, что в таблице есть данные о возрасте. Мы хотим дать, если возраст больше или равен 18 лет, должен вернуть «Правомочные», если не вернуть «Недопустимые».

На изображении выше соблюдайте формулу, которая выделена. Формула представляет собой комбинацию логического оператора If и оператора сравнения> =. Ячейка C2 возвращает «Не соответствует», потому что 17 не больше 18 и не равно 18, следовательно, она не удовлетворяет условию оператора сравнения и, следовательно, возвращает отрицательные результаты.

Соблюдайте C4, который возвращает «Правомочное», потому что 26 больше 18. Одно из условий больше, чем удовлетворяет, даже если равное условие не удовлетворяет, возвращает положительные результаты.

Соблюдайте C5, который возвращает «Правомочный», потому что он точно соответствует 18, следовательно, он возвращает положительные результаты.

Больше или равно в Excel — Пример № 7

Решение условий с использованием Greater than или Equal в Excel:

Рассмотрим в таблице данные с процентами студентов. Логика должна проверять, является ли процент учащегося больше или равен 35, что означает, что он должен давать результаты как «Пропуск», если ученик набрал менее 35 процентов, он должен давать результат как «Неудача».

На рисунке выше соблюдайте формулу, в которой используется оператор больше или равно.

Ячейка C2 возвращает «Pass», поскольку процентное значение, набранное A, равно 60, что больше 35.

Ячейка C4 возвращает «Fail», потому что процент, набранный C, меньше 35.

Ячейка C6 возвращает «Pass», потому что процент, набранный E, равен 35.

Больше или равно в Excel — Пример № 8

Больше или равно применение к строкам:

Мы можем применить оператор Greater than или equal для строк. На картинке ниже он возвращает «False», потому что A меньше, чем S, так как A предшествует S, а значит, дает результат «False».

Если мы поменяем имена, они должны вернуть «True», мы проверим это сейчас.

Соблюдайте формулу, которую мы поменялись именами, и в результате получим «True». Это способ, как больше или равно работает для строк. В случае, если первая буква одинакова в обеих ячейках, она сравнивает вторую букву и возвращает результаты.

Вещи, чтобы помнить о больше или равно в Excel

  • Больше или равно один из операторов сравнения.
  • Он проверяет условие двумя способами: один: A> B или A = B, если какое-либо условие удовлетворяет, возвращает положительные результаты.

Рекомендуемые статьи

Это было руководство к «Больше или равно» в Excel. Здесь мы обсудили «Больше или равно» в Excel и Как использовать «Больше или равно» в Excel вместе с практическими примерами и загружаемым шаблоном Excel. Вы также можете просмотреть наши другие предлагаемые статьи —

Вложенные ЕСЛИ

В EXCEL 2007 в качестве значений аргументов значение_если_истина и значение_если_ложь можно для построения более сложных проверок использовать до 64 вложенных друг в друга функций ЕСЛИ() .
=ЕСЛИ(A1>=100;"Бюджет превышен";ЕСЛИ(A1>=90;"Крупный проект";ЕСЛИ(A1>=50;"Средний проект";"Малый проект ")))

Вышеуказанную формулу можно усложнять и дальше, но есть другие подходы:

Для функции ВПР() необходимо создать в диапазоне A3:B6 таблицу значений:

Если требуется вывести разный текст в случае наличия в ячейке А1 отрицательного значения, положительного значения или 0, то можно записать следующую формулу:

или, если требуется вместо текстовых значений вывести формулы, можно использовать ссылки на диапазон ячеек (содержащих формулы)

=ПРОСМОТР(A24;<-1E+307;0;1E-307>;A27:A29) (см. файл примера )

Примеры функций И, ИЛИ

Также при использовании в Экселе функции ЕСЛИ есть возможность соединить ее с простыми операторами сравнения (вроде И, ИЛИ). Например, можно написать такое условие: =ЕСЛИ(И(A1<=5; A1>3); «проходит», «не проходит»). Получается следующее условие: если оценка студента меньше или равна 5 и больше 3, то будет показан комментарий «проходит», в противном случае — «не проходит» (проходят только те студенты, у которых в оценках стоят четверки и пятерки).

Более сложный пример использования функции ЕСЛИ - с использованием условий И либо ИЛИ

Более сложный пример использования функции ЕСЛИ — с использованием условий И либо ИЛИ

Следующее условие с примером оператора ИЛИ: =ЕСЛИ(ИЛИ(A1=5; A1=10); 100; 0). Получается, что если число в ячейке А1 равняется 5 или 10, то программа выдаст 100, в противном случае — 0.

Кроме того, можно применять эти простые операторы и для решения более сложных задач. Например, в базе данных необходимо отобрать должников, которые должны более 10 тысяч рублей и уже не платили более 6 месяцев. Если программа найдет такого человека, то пусть выдаст критерий «проблемный заемщик».

Допустим, в ячейке A1 находится информация о сроке задолженности (в месяцах), а в поле B1 — сумма задолженности. Тогда формула будет выглядеть следующим образом: =ЕСЛИ(И(A1>=6; B1>10000); «проблемный заемщик»; «»). Если будет найден человек, который подходит под указанное условие, то программа напишет напротив его фамилии комментарий «проблемный заемщик», в противном случае ячейка останется пустой.

Читайте так же:
Можно ли играть на macbook air

Если один из параметров считается критическим, тогда можно составить формулу так: =ЕСЛИ(ИЛИ(A1>=6; B1>10000); «критическая ситуация»; «»). Если программа найдет совпадения хотя бы по одному параметру (либо срок, либо сумма задолженности), то пользователь увидит сообщение о том, что ситуация критическая. Разница с предыдущей формулой в том, что в первом случае сообщение «проблемный заемщик» выдавалось только тогда, когда выполнялись оба условия.

Как в Excel при помощи вложенных функций ЕСЛИ() рассчитать бонус с продаж

Возможность проведения логических проверок в ячейках является мощным инструментом. Вы найдете бесконечное количество применений для ЕСЛИ() в ваших повседневных документах. Проблема заключается в том, что часто необходимые проверки выходят за рамки возможностей простой функции ЕСЛИ(). Это происходит, когда необходимо сделать проверку на два и более условия до принятия результата.

Для таких случаев в Excel предусмотрено несколько вариантов: использование ЕСЛИ() внутри другого ЕСЛИ(), функции И() и ИЛИ(). Далее мы познакомимся с этими способами.

Использование ЕСЛИ() внутри другой функции ЕСЛИ()

Давайте рассмотрим вариант на основе изученной ранее функции =ЕСЛИ(А1>1000;»много»; «мало») . Что если вам необходимо вывести другую строку, когда число в А1 является, например, большим, чем 10.000? Другими словами, если выражение А1>1000 верно, вы захотите запустить другую проверку и посмотреть, верно ли, что А1>10000. Такой вариант вы можете создать, применив вторую функцию ЕСЛИ() внутри первой в качестве аргумента значение _если_истина: =ЕСЛИ(А1>1000;ЕСЛИ(А1>10000;»очень много»; «много»);»мало») .

Если А1>1000 является истинным, запускается другая функция ЕСЛИ(), возвращающая значение «очень много», когда А1>10000. Если же при этом А1 меньше или равно 10000, возвращается значение «много». Если же при самой первой проверке число А1 будет меньше 1000, выведется значение «мало».

Обратите внимание, что с таким же успехом вы можете запустить вторую проверку, в случае если первая будет ложной (то есть в аргументе значение_если_ложь функции еслио ). Вот небольшой пример, возвращающий значение «очень мало», когда число в А1 меньше 100: =ЕСЛИ(А1>1000;»много»;ЕСЛИ(А1<100;»очень мало»; «мало»)) .

Расчет бонуса с продаж

Хорошим примером использования одной проверки внутри другой проверки является расчет бонуса с продаж персоналу. который работает в Клуб — отель Гелиопарк Талассо, Звенигород. В данном случае, если значение равно X, вы хотите получить один результат, если У — другой, если Z
— третий. Например, в случае вычисления бонуса за успешные продажи возможны три варианта:

  1. Продавец не достиг планового значения, бонус равен 0.
  2. Продавец превысил плановое значение менее чем на 10%, бонус равен 1 000 рублей.
  3. Продавец превысил плановое значение более чем на 10%, бонус равен 10 000 рублей.

Вот формула для расчета такого примера: =ЕСЛИ(Е3>0;ЕСЛИ(Е3>0.1;10000;1000);0) . Если значение в Е3 является отрицательным, то возвращается 0 (нет бонуса). В случае когда результат положительный, проверяется, больше ли он 10%, и в зависимости от этого выдается 1 000 или 10 000. Рис. 4.17 показывает пример работы формулы.

Рис. 4.17. Пример расчета бонуса с продаж

Рис. 4.17. Пример расчета бонуса с продаж

Функция И()

Часто бывает необходимо провести проверку только на верность одновременно двум условиям. Например, выплата бонуса осуществляется, только когда продажи определенного товара превысили план и также общие продажи превысили план. Если одно из данных условий не выполняется (или оба условия), премия не выплачивается. В булевой логике это называется логическим И, поскольку оба условия должны быть истинны для истинности всего выражения.

В Excel выражения логического И обрабатываются с помощью функции И(): И(логическое_значение1;логическое_значение2;…). Каждый аргумент представляет собой логическое значение для проверки. Вы можете ввести столько аргументов, сколько вам необходимо.

Еще раз отметим работу функции:

  • Если все выражения возвращают ИСТИНА (или любое положительное число), И() возвращает ИСТИНА.
  • Если один или более аргументов возвращают ЛОЖЬ (или 0), И() возвращает ЛОЖЬ.

Чаще всего И() применяется внутри функции ЕСЛИ(). В таком случае, когда все аргументы внутри И() вернут ИСТИНА, функция ЕСЛИ() пойдет по своей ветке значение если истина. Если одно или более из выражений в И() вернет ЛОЖЬ, функция ЕСЛИ() пойдет по ветке значение_если_ложь.

Вот небольшой пример: =ЕСЛИ(И(С2>0;В2>0);1000;»нет бонуса») . Если значение в В2 будет больше нуля и значение в С2 будет больше нуля, формула вернет 1000, в противном случае выведется строка «нет бонуса».

Разделение значений по категориям

Полезным применением функции и () является разделение по категориям в зависимости от значения. Например, у вас имеется таблица с результатами какого-то опроса или голосования, и вы хотите разделить все голоса на категории в соответствии со следующими возрастными рамками: 18-34,35-49, 50-64,65 и более. Предполагая, что возраст респондента находится в ячейке В9, следующие аргументы функции и () проводят логическую проверку на принадлежность возраста диапазону: =И(В9>=18;В9 .

Рис. 4.18. Разделение значений по категориям

Рис. 4.18. Разделение значений по категориям

Если ответ человека находится в ячейке С9, следующая формула выведет результат голосования человека, если срабатывает проверка на соответствие возрастной группе 18-34: =ЕСЛИ(И(В9>=18;В9 . На рис. 4.18 вы видите определенную информацию по данному примеру. Вот формулы, использующиеся в других столбцах:

  • 35-49: =ЕСЛИ(И(В9>=35;В9 =50;В9 =65;С9;»»)
Читайте так же:
Можно ли изменить тип файла

Функция ИЛИ()

Существуют ситуации, когда вам необходимо решение, только когда одно из условий принимает положительное значение (ИСТИНА). Например, вы можете решить выплатить бонус сотрудникам, когда общие продажи превышают план или когда продажи отдельного товара превысили прогноз. В булевой логике это называется логическим ИЛИ.

Такие условия проверяются в Excel с помощью функции ИЛИ(): ИЛИ(логическое_значение1; логическое_значение2;. ). Каждый аргумент представляет собой логическое значение для проверки. Вы можете ввести столько аргументов, сколько вам необходимо. Результат работы ИЛИ() зависит от следующих условий:

  • Если один аргумент или более возвращает ИСТИНУ (любое положительное число), ИЛИ() возвращает ИСТИНУ.
  • Если все аргументы возвращают ЛОЖЬ (нулевое значение), результатом работы ИЛИ() будет ЛОЖЬ.

Так же как и И(), чаще всего функция ИЛИ() используется внутри проверки ЕСЛИ(). В таком случае, когда один из аргументов внутри ИЛИ() вернет ИСТИНА, функция ЕСЛИ() пойдет по своей ветке значение_если_истина. Если все выражения в ИЛИ() вернут ЛОЖЬ, функция ЕСЛИ() пойдет по ветке значение_если_ложь. Вот небольшой пример: = ЕСЛИ(ИЛИ(С2>0;В2>0);1000;»нет бонуса») .

В случае когда в одной из ячеек (С2 или В2) будет положительное число, функция вернет 1000. Только когда оба значения будут отрицательны (или равны нулю), функция вернет строку «нет бонуса».

I. Сообщение темы и постановка целей урока

Учитель сообщает тему и цели урока.

II. Актуализация знаний и умений учащихся

Для чего предназначены электронные таблицы?
Ответ: Для автоматизации расчетов в табличной форме.

Что обозначает принцип относительной адресации?
Ответ. Адреса ячеек, которые используются в формулах, определены относительно места расположения формулы.

К чему приводит принцип относительной адресации при перемещений формул?
Ответ. Этот принцип приводит к тому, что при всяком перемещении формулы в другое место таблицы изменяются имена ячеек в формуле.

Если копировать содержимое E20 в E25, то какая формула будет занесена в E25 (рис. 1)?

Рис. 1
Ответ. При смещении формулы вниз на одну ячейку всякий раз в именах ячеек номер строки будет увеличиваться на единицу. Таким образом, в ячейке E25 будет формула =C25*D25.

Таблица та же (см. рис. 1). Если копировать содержимое E20 в F23, то какая формула будет занесена в F23?
Ответ. При смещении формулы вправо или влево (вдоль строки) в именах ячеек изменится буквенная часть. Таким образом, в ячейке E23 будет формула =D23*E23.

Что обозначает принцип абсолютной адресации и какой символ используется для задания абсолютной адресации?
Ответ. Адреса ячеек, используемые в формулах, определены абсолютно и при перемещении не изменяются. Для задания абсолютной адресации используется символ $.

Дан фрагмент электронной таблицы (рис. 2). Если копировать содержимое D10 в F12, то какая формула будет занесена в F12?
Рис. 2
Ответ. =$C$11+D12.

III. Актуализация знаний (создание проблемной ситуации)

Презентация «Условная функция»

Мы хотим с помощью электронных таблиц решить следующую задачу.

Задача (Слайд 2)

Разработать таблицу, содержащую следующую информацию об абитуриентах: фамилия, оценки за экзамены по математике, русскому и иностранному языкам, сумма баллов за три экзамена и информацию о зачислении: если сумма баллов больше или равна проходному баллу и оценка по математике – 4 или 5, то абитуриент зачислен в учебное заведение, в противном случае – нет.

Давайте обсудим, какую информацию надо занести в электронные таблицы, какие задать формулы.

После обсуждения с учениками приходим к виду электронных таблиц, показанному на рис. 3.

Решение задачи осуществляется в Приложении 1

В ячейке С1 будет храниться значение проходного балла – 13. Формула в ячейке E3 вычисляет сумму баллов за три экзамена (воспользуемся встроенной функцией СУММ: =СУММ (B3:D3)). Эту формулу мы скопируем в ячейки E4:E6.

А какую формулу надо задать в ячейке F3?

Создана проблемная ситуация, для преодоления которой ученикам необходимы новые знания.

IV. Ознакомление с новым материалом

Ознакомление с новым материалом ведется с использованием презентации и лазерного проектора.

Слайд 3: общий вид условной функции

Условная функция, записанная в ячейку таблицы, выполняется так: если условие истинно, то значение данной ячейки будет равно значению выражения <выражение 1>, в противном случае – <выражение 2>.

Слайд 4: построение логических выражений (общий случай).

Логические выражения строятся с помощью операций отношения (<, >, <= (меньше или равно), >= (больше или равно), <> (не равно)) и логических операций (логическое И, логическое ИЛИ, логическое отрицание НЕ). Результатом вычисления логического выражения является логическая величина ИСТИНА или ЛОЖЬ.

Слайд 5: особенности записи логических операций в электронных таблицах.

  1. Записываем имя логической операции (И, ИЛИ, НЕ)
  2. В круглых скобках перечисляются логические операнды.

Вернемся к решению задачи 1:

Читайте так же:
Как включить перенос слов в ворде 2007

В ячейку E3 введём формулу: СУММ (B3:D3) и скопируем эту формулу в ячейки E4:E8.

Условие, записанное с помощью логической операции И, можно расшифровать так: сумма баллов (E3) >= проходному баллу (C1) И оценка за экзамен по математике (B3) > 3. Если условие выполняется, то в клетке F3 будет отображаться текст «зачислен», в противном случае – «не зачислен».

В ячейку F3 надо занести формулу =ЕСЛИ(И (E3>=C1;B3>3); "зачислен"; "не зачислен"). Для проходного балла в формуле будет использоваться содержимое ячейки C1. Но так как значение ячейки C1 не меняется (проходной балл является одинаковым и неизменным для всех абитуриентов), то на эту ячейку необходимо сделать абсолютную ссылку. То есть наша формула будет выглядеть так:

Далее надо скопировать эту формулу в ячейки F4:F6. Формулы в столбике F после копирования будут выглядеть так:


Слайд 6: простой пример с подробным объяснением учителя.

Таблица содержит следующие данные об учениках школы: фамилия, возраст и рост ученика. Кто из учеников может заниматься в баскетбольной секции, если туда принимают детей с ростом не менее 160 см? Возраст не должен превышать 13 лет.

Решение задачи осуществляется в Приложении 2

Решение.

Исходной информацией являются фамилии учеников, их возраст и рост. Готовим таблицу, представленную на рис. 4.

В ячейку D2 заносим формулу для определения, кто из учеников школы может заниматься в секции, а кто – нет:

Таким образом, если оба условия выполняются (т.е. если рост ученика не менее 160 см и возраст не превышает 13 лет), то в ячейке D2 будет отображаться текст «Да», в противном случае – «Нет».


Слайд 7: простой пример, объяснить который должны ученики.

6 спортсменов – многоборцев принимают участие в соревнованиях по 5 видам спорта. По каждому виду спорта спортсмен набирает определённое количество очков. Спортсмену присваивается звание мастера, если он набрал в сумме 100 и более очков. Сколько спортсменов получило звание мастера

Решение задачи осуществляется в Приложении 3

Решение.

Готовим таблицу в виде, представленном на рис. 5.

В ячейки В2:F7 заносим результаты учеников по каждому виду спорта. В ячейку G2 — формулу =СУММ(B2:F2). Далее копируем эту формулу для ячеек GЗ:G7.

В ячейку H2 – формулу =ЕСЛИ(G2>=100;"мастер";"нет звания"). Таким образом, если условие, что общее количество очков больше или равно 100, выполняется для данного спортсмена , то в соответствующей ячейке столбца H будет отображаться текст «мастер», в противном случае – «нет звания».

В ячейку I2 – формулу =ЕСЛИ(H2="мастер";1;0) . Таким образом, если условие, что спортсмен является мастером выполняется, то в соответствующей ячейке столбца I будет отображаться 1, в противном случае — 0.

В ячейку I8 – формулу =СУММ(I2:I7). Таким образом можно подсчитать общее количество спортсменов, имеющих звание «Мастер спорта».


Слайд 8: более сложный пример с подробным объяснением учителя.

Покупатели магазина пользуются 10% скидками, если стоимость покупки превышает k рублей. Составить ведомость, учитывающую скидки: покупатель, стоимость покупки, скидка, стоимость покупки с учётом скидки. Составить таблицу и показать, кто из покупателей сделал покупки со скидкой, стоимость которых превышает k рублей.

Решение задачи осуществляется в Приложении 4

Решение.

Готовим таблицу в виде, представленном на рис. 6.

В ячейки A1:B7 заносим соответствующие данные.

В ячейку C2 заносим формулу =B2*0,1 (так как скидка на покупку 10%, то изначальную стоимость покупки необходимо умножить на 0,1).

В ячейку D2 заносим формулу =B2-C2 (так как стоимость мы вычисляем покупки с учётом скидки)

В ячейку E2 заносим формулу =ЕСЛИ(B2>=$B$9;D2;B2). В этой формуле необходимо обратить внимание на абсолютную ссылку на ячейку B9.

При занесении формулы в ячейку E2 мы встретились с ситуацией, когда при вставке встроенной функции ЕСЛИ требуется в качестве значения логического выражения сделать ссылку на ячейку.

V. Этап закрепления знаний

Самостоятельная работа учащихся за компьютерами

Учащимся предлагаются задания трех уровней сложности.

Задача (уровень 1).

Покупатель магазина получает скидку 3%, если у него есть дисконтная карта или если общая стоимость его покупки превышает 5000 рублей. Определить, сколько заплатили покупатели за свои покупки.

Задача (уровень 2).

В доме проживают 10 жильцов. Подсчитать, сколько каждый из них должен платить за электроэнергию и определить суммарную плату для всех жильцов. Известно, что 1 кВт/ч электроэнергии стоит m рублей, а некоторые жильцы имеют 50% скидку при оплате (например пенсионеры).

Задача (уровень 3).

Если количество баллов, полученных при тестировании, не превышает 12, то это соответствует оценке «2»; оценке «3» соответствует количество баллов от 12 до 15; оценке «4» – от 16 до 20; оценке «5» — свыше 20 баллов. Составить ведомость тестирования, содержащую сведения: фамилия, количество баллов, оценка.

VI. Проверка работы учащихся

Демонстрируются заранее подготовленные файлы с результатами решения.

VII. Подведение итогов урока

Подводятся итоги урока, выставляются оценки с аргументацией.

Читайте так же:
Диспетчер сценариев в excel

VIII. Домашнее задание

Каждому ученику выдается карточка, домашнее задание комментируется. Предлагаются задачи двух уровней сложности.

Задача (уровень 1). Каждому пушному зверьку от 1-го до 2-ч месяцев полагается дополнительный стакан молока в день, если его вес меньше 3-х кг. Количество зверьков, возраст и вес каждого известны. Выяснить, сколько литров молока в месяц необходимо для зверофермы. Один стакан молока составляет 0,2 литра.

Задача (уровень 2). Если вес пушного зверька в возрасте от 6-ти до 7-ми месяцев превышает 7 кг, то необходимо снизить дневное потребление витаминного концентрата на 125 г. Количество зверьков, возраст и вес каждого известны. Выяснить на сколько килограммов в месяц снизится потребление витаминного концентрата.

Дата в качестве условия, с которым работает функция ЕСЛИ, может быть записана в какую-то ячейку Excel, либо же прямо вставлена в формулу. Вот тут-то и возникают некоторые особенности и сложности работы функции ЕСЛИ с датами.

Пример 1. Формула условия для дат с функцией ДАТАЗНАЧ (DATEVALUE)

Иногда случается, что записать дату непосредственно в функцию ЕСЛИ, не ссылаясь ни на какую ячейку. В этом случае возникают некоторые сложности.

В отличие от многих других функций Excel, ЕСЛИ не может распознавать даты и интерпретирует их как текст, как простые текстовые строки.

Поэтому вы не можете выразить свое логическое условие просто как >«15.07.2019» или же >15.07.2019. Увы, ни один из приведенных вариантов не верен.

Чтобы функция ЕСЛИ распознала дату в вашем логическом условии именно как дату, вы должны обернуть ее в функцию ДАТАЗНАЧ (в английском варианте – DATEVALUE).

Полная формула ЕСЛИ может иметь следующую форму:

Как показано на скриншоте, эта формула ЕСЛИ оценивает даты в столбце В и возвращает «Послупил», если дата поступления до 10 сентября. В противном случае формула возвращает «Ожидается».

Пример 2. Формула условия для дат с функцией СЕГОДНЯ()

В случае, когда даты записаны в ячейки таблицы Excel, применять ДАТАЗНАЧ нет необходимости.

Если вы основываете свое условие на текущей дате, то можете взять функцию СЕГОДНЯ (в английском варианте — TODAY) в качестве аргумента функции ЕСЛИ.

К примеру, сегодня — 9 сентября 2019 года.

В столбце C отметим товар, который уже поступил. В ячейке C2 запишем:

В столбце D отметим товар, который еще не поступил. В ячейке D2 запишем:

Пример 3. Расширенные формулы ЕСЛИ для будущих и прошлых дат

Предположим, вы хотите отметить только те даты, которые отстоят от текущей более чем на 30 дней.

Выделим даты, отстоящие более чем на месяц от текущей, в прошлом. Укажем для них «Более месяца назад». Запишем это условие:

=ЕСЛИ(СЕГОДНЯ()-B2>30,»Более месяца назад»,»»)

Если условие не выполнено, то в ячейку запишем пустую строку «».

А для будущих дат, также отстоящих более чем на месяц, укажем «Ожидается».

Если все результаты попробовать объединить в одном столбце, то придется составить выражение с несколькими вложенными функциями ЕСЛИ:

=ЕСЛИ(СЕГОДНЯ()-B2>30,»Более месяца назад», ЕСЛИ(B2-СЕГОДНЯ()>30,»Ожидается»,»»))

ЕСЛИ с датами

Примеры работы функции ЕСЛИ:

Функция МАКС в Excel: как найти максимальное значение — В этой статье объясняется функция МАКС с множеством примеров формул, которые показывают, как найти наибольшее значение в Excel и выделить наибольшее число на листе. МАКС — одна из самых простых…
Как сравнить два столбца на совпадения и различия — На прочтение этой статьи у вас уйдет около 10 минут, а в следующие 5 минут (или даже быстрее) вы легко сравните два столбца Excel на наличие дубликатов и выделите найденные…
Сравнение ячеек в Excel — Вы узнаете, как сравнивать значения в ячейках Excel на предмет точного совпадения или без учета регистра. Мы предложим вам несколько формул для сопоставления двух ячеек по их значениям, длине или количеству…
проверка правильности ввода Excel при помощи функции ЕСЛИ Как проверить правильность ввода данных в Excel? — Подтверждаем правильность ввода галочкой. Задача: При ручном вводе данных в ячейки таблицы проверять правильность ввода в соответствии с имеющимся списком допустимых значений. В случае правильного ввода в отдельном столбце ставить…
alt=»ЕСЛИ + СОВПАД текст» width=»250″ height=»95″ /> Функция ЕСЛИ: проверяем условия с текстом — Рассмотрим использование функции ЕСЛИ в Excel в том случае, если в ячейке находится текст. СодержаниеПроверяем условие для полного совпадения текста.ЕСЛИ + СОВПАДИспользование функции ЕСЛИ с частичным совпадением текста.ЕСЛИ + ПОИСКЕСЛИ…
функция если Визуализация данных при помощи функции ЕСЛИ — Функцию ЕСЛИ можно использовать для вставки в таблицу символов, которые наглядно показывают происходящие с данными изменения. К примеру, мы хотим показать в отдельной колонке таблицы, происходит рост или снижение продаж.…
Функция ЕСЛИ в Excel – примеры использования — на примерах рассмотрим, как можно использовать функцию ЕСЛИ в Excel, а также какие задачи мы можем решить с ее помощью

голоса
Рейтинг статьи
Ссылка на основную публикацию
Adblock
detector